cwlr.net
当前位置:首页 >> myEClipsE运行报错jAvA.lAng.UnsupportEDClAssVErs... >>

myEClipsE运行报错jAvA.lAng.UnsupportEDClAssVErs...

JDK版本问题 ,服务器支持的JDK版本和Web项目不兼容,不懂你用的是不是weblogic ,好像11g是支持JAVA1.6的,解决办法 你试下降低web项目的JDK版本

这个问题确实是由较高版本的JDK编译的java class文件试图在较低版本的JVM上运行产生的错误。 1、解决措施就是保证jvm(java命令)和jdk(javac命令)版本一致。如果是linux版本,则在命令行中分别输入java -version和javac -version命令来查看...

原因:你的项目编译时用的JDK版本较高,tomcat用的jdk版本过低导致无法运行。 解决方法就是把两者JDK变成一样的: 1.如果你不想改tomcat的jdk版本的话,就用写的第一种方法,compiler compliance level选择1.5 2.如果你不想用第一种方法,第二种...

你好 项目中导入servlet.jar试试 或者重新加载maven的jre 希望回答对你有帮助

从错误上看,是java版本问题,jdk版本低才会报这个错误 不过看你的项目上有一个红色感叹号!,这说明classpath引入的jar包有问题,查看一下。

是打开后才出现这个 还是双击Eclipse就出现这个窗口 要是双击就出现那是你环境没搭配好 你运行Dos指令 输入 Java -version 注意 “-”前面有个空格啊 你输入后看下是否有出现你JDK的版本 例如下面这张图

如果Eclipse的JDK编译器使用的是JDK6,就换成5; 如果Eclipse的JDK编译器使用的是JDK5,就换成6;

一般是低版本jre运行高版本编译出来的class 例如: 运行环境的jvm是1.5,但是class是1.6编译出来的。 换一个高版本的jre,设置path变量,重新试试看。

安装JVM的时候环境没有设置好..在系统环境里面把你安装JVM的路径加到里面去.. 按下面配置就搞定: 2.1,新建系统变量: 变量名:JAVA_HOME 变量值:C:\Program Files\Java\jdk1.5.0_17(该目录为JDK安装的目录) 2.2,编辑CLASSPATH,如果没有该变...

junit:junit:jar 是不是在同一个pom文件多次引用了 但是版本不一致?

网站首页 | 网站地图
All rights reserved Powered by www.cwlr.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com